summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 11188fb2..31fe60b3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -222,9 +222,6 @@ xyes)
;;
esac
-AC_CHECK_LIB(c, pthread_self, [thrstubs="no"], [thrstubs="yes"])
-AM_CONDITIONAL(THRSTUBS, test x$thrstubs = xyes)
-
# XXX incomplete, please fill this in
if test x$xthreads = xyes ; then
case $host_os in
@@ -245,6 +242,14 @@ fi
AC_SUBST(XTHREADLIB)
AC_SUBST(XTHREAD_CFLAGS)
+if test "x$USE_THREAD_SAFETY_CONSTRUCTOR" = "xyes"; then
+ USE_THREAD_LIBS="$XTHREADLIB"
+fi
+AC_SUBST(USE_THREAD_LIBS)
+
+AC_CHECK_LIB(c, pthread_self, [thrstubs="no"], [thrstubs="yes"], [$USE_THREAD_LIBS])
+AM_CONDITIONAL(THRSTUBS, test x$thrstubs = xyes)
+
AC_CHECK_FUNC(poll, [AC_DEFINE(USE_POLL, 1, [poll() function is available])], )
#