summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2010-02-16 10:37:21 -0500
committerGaetan Nadon <memsize@videotron.ca>2010-02-16 10:37:21 -0500
commitceaddfbd0f55c4863bed9c42fcce1fad0348ad19 (patch)
treeffab2e791137d870c303e710472bc588de9a3464 /src/Makefile.am
parent17eeac2a9218f5d22c71d18eee9ec1fe64bdbf5a (diff)
downloadxorg-lib-libXRes-ceaddfbd0f55c4863bed9c42fcce1fad0348ad19.tar.gz
config: move CWARNFLAGS from configure.ac to Makefile.am
Compiler warning flags should be explicitly set in the makefile rather than being merged with other packages compiler flags. Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index a64c939..fd508da 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -5,7 +5,10 @@ libXRes_la_SOURCES = \
libXRes_la_LIBADD = @XRES_LIBS@
-AM_CFLAGS = $(CWARNFLAGS) @XRES_CFLAGS@ @MALLOC_ZERO_CFLAGS@
+AM_CFLAGS = \
+ $(CWARNFLAGS) \
+ $(XRES_CFLAGS) \
+ $(MALLOC_ZERO_CFLAGS)
INCLUDES = -I$(top_srcdir)/include