summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJosh Triplett <josh@speakeasy.net>2005-05-14 07:46:48 +0000
committerJosh Triplett <josh@speakeasy.net>2005-05-14 07:46:48 +0000
commit9607573553c23bcdfb1c3eaec3571aa52fdeb5ee (patch)
tree939abcca5ec14be3c8b2cde877809b7641ffa6dc /Makefile.am
parent56a655e717c5de6d91c890fdc6f9b0469ad1dd1a (diff)
downloadxorg-lib-libXau-9607573553c23bcdfb1c3eaec3571aa52fdeb5ee.tar.gz
Move includes in Xau and Xdmcp into include/X11 subdirectories so that the
source can reference them with <X11/...>.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index fabfb8f..82211ca 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,9 @@
lib_LTLIBRARIES = libXau.la
+AM_CFLAGS = $(XAU_CFLAGS)
+
+INCLUDES = -I${top_srcdir}/include
+
libXau_la_LDFLAGS = -version-number 6:0:0 -no-undefined
libXau_la_LIBADD = $(XAU_LIBS)
@@ -20,7 +24,7 @@ endif KERBEROS
xauincludedir=$(includedir)/X11
-xauinclude_HEADERS = Xauth.h
+xauinclude_HEADERS = include/X11/Xauth.h
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = xau.pc