summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2013-03-30 10:55:26 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2013-03-30 10:55:26 -0700
commit325f5282bc1d93b72b0b05037245cf130970fa38 (patch)
tree02dd6a2fdc046a182dbd9f56c596b8f1014d8284 /configure.ac
parent1a8a1b2c68967b48c07b56142799b1020f017027 (diff)
downloadxorg-lib-libXau-325f5282bc1d93b72b0b05037245cf130970fa38.tar.gz
Use configure check for pathconf instead of X_NOT_POSIX #define
Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 62a4717..e55cfce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,6 +26,7 @@ AC_INIT([libXau], [1.0.7],
[https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [libXau])
AC_CONFIG_SRCDIR([Makefile.am])
AC_CONFIG_HEADERS([config.h])
+AC_USE_SYSTEM_EXTENSIONS
# Initialize Automake
AM_INIT_AUTOMAKE([foreign dist-bzip2])
@@ -43,6 +44,9 @@ XORG_DEFAULT_OPTIONS
# Checks for programs.
AC_PROG_LN_S
+# Checks for library functions.
+AC_CHECK_FUNCS([pathconf])
+
# Obtain compiler/linker options for depedencies
PKG_CHECK_MODULES(XAU, xproto)