summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-05-09 22:04:21 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-05-09 22:04:21 +0000
commit60177d823918d9ef7575da27870796c1285a2032 (patch)
tree3e58d1222fe9382494e92a0019e0daea95b2d9e6 /configure.ac
parent62b6efa4e0012fc499d2c70bff7b99b468a0458f (diff)
downloadxorg-lib-libXau-60177d823918d9ef7575da27870796c1285a2032.tar.gz
Add Xau library to lib/ and symlink.sh
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac55
1 files changed, 55 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..815f306
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,55 @@
+dnl
+dnl $Id$
+dnl
+dnl Copyright © 2003 Keith Packard, Noah Levitt
+dnl
+dnl Permission to use, copy, modify, distribute, and sell this software and its
+dnl documentation for any purpose is hereby granted without fee, provided that
+dnl the above copyright notice appear in all copies and that both that
+dnl copyright notice and this permission notice appear in supporting
+dnl documentation, and that the name of Keith Packard not be used in
+dnl advertising or publicity pertaining to distribution of the software without
+dnl specific, written prior permission. Keith Packard makes no
+dnl representations about the suitability of this software for any purpose. It
+dnl is provided "as is" without express or implied warranty.
+dnl
+dnl KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+dnl INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+dnl EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+dnl CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+dnl DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+dnl TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+dnl PERFORMANCE OF THIS SOFTWARE.
+dnl
+dnl Process this file with autoconf to create configure.
+
+AC_PREREQ([2.57])
+AC_INIT(libXau, [0.1.2], [keithp@keithp.com],libXau)
+AM_INIT_AUTOMAKE([dist-bzip2])
+AM_MAINTAINER_MODE
+
+AM_CONFIG_HEADER(config.h)
+
+AC_PROG_CC
+AC_PROG_INSTALL
+AC_PROG_LN_S
+AC_LIBTOOL_WIN32_DLL
+AM_PROG_LIBTOOL
+AC_PROG_MAKE_SET
+
+PKG_CHECK_MODULES(XAU, xproto)
+AC_SUBST(XAU_CFLAGS)
+AC_SUBST(XAU_LIBS)
+
+kerberos=false
+AM_CONDITIONAL(KERBEROS, test x$kerberos = xtrue)
+
+if test "x$GCC" = "xyes"; then
+ GCC_WARNINGS="-Wall -Wpointer-arith -Wstrict-prototypes \
+ -Wmissing-prototypes -Wmissing-declarations \
+ -Wnested-externs -fno-strict-aliasing"
+ XAU_CFLAGS="$GCC_WARNINGS $XAU_CFLAGS"
+fi
+
+AC_OUTPUT([Makefile
+ xau.pc])