summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-04-23 19:14:22 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-04-23 19:14:22 -0700
commit81a8a71d888d16989a096195dfd96b10fadeba5d (patch)
tree21474be95daf5c83937970f31c45ab139645f1d5 /Makefile.am
parent3d6927c680e6aba14e0a7d771ce8891606cb7fbd (diff)
downloadxorg-lib-libXcomposite-81a8a71d888d16989a096195dfd96b10fadeba5d.tar.gz
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index bb67cf6..3219ccc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,4 +26,10 @@ SUBDIRS = src man
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = xcomposite.pc
-EXTRA_DIST = xcomposite.pc.in autogen.sh
+EXTRA_DIST = xcomposite.pc.in autogen.sh ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog
+