summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2010-01-21 20:03:42 -0500
committerGaetan Nadon <memsize@videotron.ca>2010-01-24 08:10:13 -0500
commit2002631bd71ba970d77f9b5c8f886c3bf1349e45 (patch)
tree26923dd33a4d0d3d6cd36366382ffcc849c87d4d /configure.ac
parent213cf861e8a29c6f991828beb6656239206c9947 (diff)
downloadxorg-lib-libXcomposite-2002631bd71ba970d77f9b5c8f886c3bf1349e45.tar.gz
man: allow installing prebuilt man pages from tarball
The man pages source may be supplied in the tarball or built from git. The makefile needs to take that into consideration and adjust the targets accordingly. This prevents the regular make target to fail when the source is not available and the xmlto is not available. Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 54ea754..f5aced9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -49,6 +49,11 @@ AC_PROG_LIBTOOL
XORG_DEFAULT_OPTIONS
XORG_WITH_XMLTO
+# Determine if the source for man pages is available
+# It may already be present (tarball) or can be generated using xmlto
+AM_CONDITIONAL([INSTALL_MANPAGES],
+ [test -f "$srcdir/man/Xcomposite.man" || test "x$have_xmlto" = xyes])
+
# Check compositeext configuration, strip extra digits from package version to
# find the required protocol version