summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2010-06-30 22:49:26 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2010-07-07 10:53:03 -0700
commit219e4de3666e3a7dda42c64ab1539a4cc5adbee4 (patch)
tree1b191634d97516f91ad0f706068ac00e4df76c3e /configure.ac
parent01c4691e18b536de6585a0e93e05e2831cf2be34 (diff)
downloadxorg-lib-libXcomposite-219e4de3666e3a7dda42c64ab1539a4cc5adbee4.tar.gz
Remove unneeded dependencies from configure.ac & xcomposite.pc
We only need Xfixes headers for the XserverRegion definition, don't need to link against it directly or require clients link against it, so only use CFLAGS from it in the Makefile, and only list it in Requires.private in the .pc file. Don't need libXext at all - no headers or functions from it are used. Also clean up some extra appearances of *_CFLAGS & *_LIBS that aren't needed. Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com> Reviewed-by: Dan Nicholson <dbn.lists@gmail.com> Acked-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 2 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 3f44a9d..e63ef8f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,9 +65,8 @@ if test "$VERSION" = "" ; then
fi
COMPOSITEEXT_VERSION=[`echo $VERSION | sed 's/^\([0-9][0-9]*\.[0-9][0-9]*\).*$/\1/'`]
AC_SUBST(COMPOSITEEXT_VERSION)
-PKG_CHECK_MODULES(XCOMPOSITE, [compositeproto >= $COMPOSITEEXT_VERSION] x11 xfixes xext fixesproto)
-AC_SUBST(XCOMPOSITE_CFLAGS)
-AC_SUBST(XCOMPOSITE_LIBS)
+PKG_CHECK_MODULES(XCOMPOSITE, [compositeproto >= $COMPOSITEEXT_VERSION] x11)
+PKG_CHECK_MODULES(XFIXES, xfixes)
AC_OUTPUT([Makefile
src/Makefile