summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2022-11-21 11:54:58 -0800
committerAlan Coopersmith <alan.coopersmith@oracle.com>2022-11-21 11:54:58 -0800
commit352885a4ff166cd065da1944649a4f12801dd4d2 (patch)
tree33d8ae93f54c96ce1e93e9641d4f61582dd48f8a /configure.ac
parent544392051e5f566c4eb29fa2e40dbce748935728 (diff)
downloadxorg-lib-libXcomposite-352885a4ff166cd065da1944649a4f12801dd4d2.tar.gz
XCompositeCloseDisplay: Mark codes as unused
Quiets clang warning: Xcomposite.c:91:50: warning: unused parameter 'codes' [-Wunused-parameter] XCompositeCloseDisplay (Display *dpy, XExtCodes *codes) ^ Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d62be07..81fd884 100644
--- a/configure.ac
+++ b/configure.ac
@@ -63,7 +63,8 @@ COMPOSITEEXT_VERSION=[`echo $VERSION | sed 's/^\([0-9][0-9]*\.[0-9][0-9]*\).*$/\
AC_SUBST(COMPOSITEEXT_VERSION)
# Obtain compiler/linker options for dependencies
-PKG_CHECK_MODULES(XCOMPOSITE, [compositeproto >= $COMPOSITEEXT_VERSION] x11)
+PKG_CHECK_MODULES(XCOMPOSITE,
+ [compositeproto >= $COMPOSITEEXT_VERSION xproto >= 7.0.22 x11])
PKG_CHECK_MODULES(XFIXES, xfixes)
AC_CONFIG_FILES([Makefile