summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2009-10-08 00:23:42 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2009-10-08 00:23:48 -0700
commitc302ae79f7819f75628f798d15c980cbf42eec91 (patch)
treefc234cff9d29ad8142bff81cc5d4e2785e87b26a /configure.ac
parent3418a26aa83fbba78ad5a214ca7db2984a44190b (diff)
downloadxorg-lib-libXcomposite-c302ae79f7819f75628f798d15c980cbf42eec91.tar.gz
Migrate to xorg macros 1.3 & XORG_DEFAULT_OPTIONS
Also some changes to man/Makefile.am to make it work better with the AM_SILENT_RULES option that's enabled in XORG_DEFAULT_OPTIONS Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 6 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index d5c0791..c944ea1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,15 +36,17 @@ AC_INIT(libXcomposite, 0.4.0, [https://bugs.freedesktop.org/enter_bug.cgi?produc
AM_INIT_AUTOMAKE([dist-bzip2])
AM_MAINTAINER_MODE
-# Require xorg-macros: XORG_CWARNFLAGS, XORG_CHANGELOG
-m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.2 or later before running autoconf/autogen])])
-XORG_MACROS_VERSION(1.2)
+# Require xorg-macros 1.3 or later: XORG_DEFAULT_OPTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.3 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.3)
AM_CONFIG_HEADER(config.h)
# Check for progs
AC_PROG_CC
AC_PROG_LIBTOOL
-XORG_CWARNFLAGS
+
+XORG_DEFAULT_OPTIONS
AC_ARG_VAR([XMLTO], [Path to xmlto command])
AC_PATH_PROG([XMLTO], [xmlto])
@@ -62,14 +64,9 @@ fi
COMPOSITEEXT_VERSION=[`echo $VERSION | sed 's/^\([0-9][0-9]*\.[0-9][0-9]*\).*$/\1/'`]
AC_SUBST(COMPOSITEEXT_VERSION)
PKG_CHECK_MODULES(XCOMPOSITE, [compositeproto >= $COMPOSITEEXT_VERSION] x11 xfixes xext fixesproto)
-XCOMPOSITE_CFLAGS="$CWARNFLAGS $XCOMPOSITE_CFLAGS"
AC_SUBST(XCOMPOSITE_CFLAGS)
AC_SUBST(XCOMPOSITE_LIBS)
-XORG_MANPAGE_SECTIONS
-XORG_RELEASE_VERSION
-XORG_CHANGELOG
-
AC_OUTPUT([Makefile
src/Makefile
man/Makefile