summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-05-17 16:47:59 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-05-17 16:47:59 +0000
commitdaa2ab8a2deff5730713c38322be53ed8facae74 (patch)
tree0a08a5f59f24401a914bcbb49fdd553581e363a5 /Makefile.am
parenta9055b6135f82bafefd05b140c9ec4a6d0b1fc9f (diff)
downloadxorg-lib-libXdamage-daa2ab8a2deff5730713c38322be53ed8facae74.tar.gz
Add Xdamage build system
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..3279789
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,33 @@
+#
+# $Id$
+#
+# Copyright © 2003 Keith Packard, Noah Levitt
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Keith Packard not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Keith Packard makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+AM_CFLAGS = $(XDAMAGE_CFLAGS) $(X_CFLAGS)
+
+SUBDIRS = src
+
+INCLUDES = $(top_srcdir)/include/
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = xdamage.pc
+
+EXTRA_DIST = xdamage.pc.in autogen.sh