summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-01-25 18:23:14 -0800
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-01-25 18:23:14 -0800
commit6856538d6dec00795f492262eb4f730735eff8d1 (patch)
tree0a5c0f05a36816e5b45ab4f47229df62e228da70 /Makefile.am
parent5243b3f7d462a06ec245b28ed007d5b4c85651ee (diff)
downloadxorg-lib-libXext-6856538d6dec00795f492262eb4f730735eff8d1.tar.gz
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 79c5a9d..0ee0095 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,4 +3,11 @@ SUBDIRS = man src
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = xext.pc
-EXTRA_DIST=xext.pc.in
+EXTRA_DIST=xext.pc.in ChangeLog autogen.sh
+MAINTAINERCLEANFILES=ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog
+