summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2011-02-02 11:43:41 -0500
committerGaetan Nadon <memsize@videotron.ca>2011-02-02 12:01:44 -0500
commit45c1b21e9f3ae64d0c65562080df925e11c0859c (patch)
tree46773116011b13afaca96be383359f61455e0636 /configure.ac
parentf9d755fc92661a6db6f9d11c4e13a8926be47a83 (diff)
downloadxorg-lib-libXext-45c1b21e9f3ae64d0c65562080df925e11c0859c.tar.gz
config: comment, minor upgrade, quote and layout configure.ac
Group statements per section as per Autoconf standard layout Quote statements where appropriate. Autoconf recommends not using dnl instead of # for comments Use AC_CONFIG_FILES to replace the deprecated AC_OUTPUT with parameters. Remove redundant AC_CANONICAL_HOST included in XORG_DEFAULT_OPTIONS Remove redundant AC_SUBST(*_CFLAGS) and/or *_LIBS No functional configuration changes This helps automated maintenance and release activities. Details can be found in http://wiki.x.org/wiki/NewModuleGuidelines Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac42
1 files changed, 18 insertions, 24 deletions
diff --git a/configure.ac b/configure.ac
index 4558c7d..5dae4f6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,17 +1,18 @@
-# -*- Autoconf -*-
-# Process this file with autoconf to produce a configure script.
+# Initialize Autoconf
AC_PREREQ([2.60])
-AC_INIT([libXext],
- [1.2.99.0],
- [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],
- [libXext])
-
+AC_INIT([libXext], [1.2.99.0],
+ [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [libXext])
AC_CONFIG_SRCDIR([Makefile.am])
-AM_INIT_AUTOMAKE([foreign dist-bzip2])
+AC_CONFIG_HEADERS([config.h])
+# Initialize Automake
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
+# Initialize libtool
+AC_PROG_LIBTOOL
+
# Require xorg-macros minimum of 1.10 for DocBook XML documentation
m4_ifndef([XORG_MACROS_VERSION],
[m4_fatal([must install xorg-macros 1.10 or later before running autoconf/autogen])])
@@ -21,11 +22,10 @@ XORG_ENABLE_SPECS
XORG_WITH_XMLTO(0.0.20)
XORG_WITH_FOP
XORG_CHECK_SGML_DOCTOOLS(1.5)
-AC_CONFIG_HEADERS([config.h])
+XORG_CHECK_MALLOC_ZERO
# Determine .so library version per platform
# based on SharedXextRev in monolith xc/config/cf/*Lib.tmpl
-AC_CANONICAL_HOST
if test "x$XEXT_SOREV" = "x" ; then
case $host_os in
openbsd*) XEXT_SOREV=8:0 ;;
@@ -35,22 +35,16 @@ if test "x$XEXT_SOREV" = "x" ; then
fi
AC_SUBST(XEXT_SOREV)
-# Checks for programs.
-AC_PROG_LIBTOOL
-
-# Checks for pkg-config packages
+# Obtain compiler/linker options for depedencies
PKG_CHECK_MODULES(XEXT, [xproto >= 7.0.13] [x11 >= 1.1.99.1] [xextproto >= 7.1.99])
-AC_SUBST(XEXT_CFLAGS)
-AC_SUBST(XEXT_LIBS)
-
-XORG_CHECK_MALLOC_ZERO
-dnl Allow checking code with lint, sparse, etc.
+# Allow checking code with lint, sparse, etc.
XORG_WITH_LINT
XORG_LINT_LIBRARY([Xext])
-AC_OUTPUT([Makefile
- man/Makefile
- src/Makefile
- specs/Makefile
- xext.pc])
+AC_CONFIG_FILES([Makefile
+ man/Makefile
+ src/Makefile
+ specs/Makefile
+ xext.pc])
+AC_OUTPUT