summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2013-11-07 16:31:16 -0800
committerAlan Coopersmith <alan.coopersmith@oracle.com>2013-11-07 16:31:16 -0800
commitbb24f2970f2e425f4df90c9b73d078ad15a73fbb (patch)
tree661b6df5aa834e864be70339bd3f17d4fd41f34b /configure.ac
parent7378d4bdbd33ed49ed6cfa5c4f73d7527982aab4 (diff)
downloadxorg-lib-libXext-bb24f2970f2e425f4df90c9b73d078ad15a73fbb.tar.gz
Remove fallback for _XEatDataWords, require libX11 1.6 for it
_XEatDataWords was orignally introduced with the May 2013 security patches, and in order to ease the process of delivering those, fallback versions of _XEatDataWords were included in the X extension library patches so they could be applied to older versions that didn't have libX11 1.6 yet. Now that we're past that hurdle, we can drop the fallbacks and just require libX11 1.6 for building new versions of the extension libraries. Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 1 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 9a1e0c2..491aac0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,13 +36,7 @@ fi
AC_SUBST(XEXT_SOREV)
# Obtain compiler/linker options for depedencies
-PKG_CHECK_MODULES(XEXT, [xproto >= 7.0.13] [x11 >= 1.1.99.1] [xextproto >= 7.1.99])
-
-# Check for _XEatDataWords function that may be patched into older Xlib releases
-SAVE_LIBS="$LIBS"
-LIBS="$XEXT_LIBS"
-AC_CHECK_FUNCS([_XEatDataWords])
-LIBS="$SAVE_LIBS"
+PKG_CHECK_MODULES(XEXT, [xproto >= 7.0.13] [x11 >= 1.6] [xextproto >= 7.1.99])
# Allow checking code with lint, sparse, etc.
XORG_WITH_LINT