summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 79c5a9d..0ee0095 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,4 +3,11 @@ SUBDIRS = man src
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = xext.pc
-EXTRA_DIST=xext.pc.in
+EXTRA_DIST=xext.pc.in ChangeLog autogen.sh
+MAINTAINERCLEANFILES=ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog
+