summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2019-08-03 16:05:21 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2019-08-03 17:12:12 -0700
commitd4c941ea8b1dc07a14efce656bff58d31a14c985 (patch)
treeaf8719ef39f2dd8da39c55a84f628c186416c97a /configure.ac
parentc4ed2e069dc8aa5b8b7ef2fc926ae8584ff2a67b (diff)
downloadxorg-lib-libXfont-d4c941ea8b1dc07a14efce656bff58d31a14c985.tar.gz
Add strlcat & strlcpy fallbacks if not provided by libc nor libbsd
Implementations copied from the Xserver Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9df20cb..970d9a3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -52,6 +52,9 @@ AC_CHECK_HEADERS([endian.h poll.h sys/poll.h])
# Checks for library functions.
AC_CHECK_FUNCS([poll readlink])
+AC_SEARCH_LIBS([strlcat], [bsd])
+AC_CONFIG_LIBOBJ_DIR([src/util])
+AC_REPLACE_FUNCS([strlcat strlcpy])
# If the first PKG_CHECK_MODULES appears inside a conditional, pkg-config
# must first be located explicitly.