summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-03-16 16:22:21 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-03-16 16:22:21 -0700
commit96c081ed52e3437ede0062eb7ccfb520879cbc0e (patch)
treea648e5be4863610823b0d13945f2b8db2b8e78f1 /Makefile.am
parent1a5b5c7e5f603528ff69468f8d6d73e2e30442a5 (diff)
downloadxorg-lib-libXinerama-96c081ed52e3437ede0062eb7ccfb520879cbc0e.tar.gz
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 1d1b515..7642d24 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,7 +24,13 @@ SUBDIRS = src man
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = xinerama.pc
-EXTRA_DIST = xinerama.pc.in autogen.sh
+EXTRA_DIST = xinerama.pc.in autogen.sh ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog
if LINT
lint: