summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-02-15 18:59:53 -0800
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-02-15 18:59:53 -0800
commitc98be137c711235fe5bff430e93222d2a47b5e6a (patch)
treecde490a617e8f6cb515e58a781cb67a538d92fe3 /configure.ac
parent269885f05a4aed0eb3ee192217fa8ec6494f90c5 (diff)
downloadxorg-lib-libXinerama-c98be137c711235fe5bff430e93222d2a47b5e6a.tar.gz
Add support for source code checkers such as sparse & lint
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e4f8ed9..e47de85 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,6 +28,10 @@ AM_MAINTAINER_MODE
AM_CONFIG_HEADER(config.h)
+# Require xorg-macros version 1.1.0 or newer for XORG_WITH_LINT macro
+m4_ifndef([XORG_MACROS_VERSION], [AC_FATAL([must install xorg-macros 1.1 or later])])
+XORG_MACROS_VERSION(1.1)
+
# Check for progs
AC_PROG_CC
AC_PROG_LIBTOOL
@@ -37,6 +41,10 @@ PKG_CHECK_MODULES(XINERAMA, x11 xext xextproto xineramaproto)
AC_SUBST(XINERAMA_CFLAGS)
AC_SUBST(XINERAMA_LIBS)
+
+dnl Allow checking code with lint, sparse, etc.
+XORG_WITH_LINT
+LINT_FLAGS="${LINT_FLAGS} ${XINERAMA_CFLAGS}"
XORG_CHECK_MALLOC_ZERO
XORG_RELEASE_VERSION