summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 16:38:32 -0500
committerJames Cloos <cloos@jhcloos.com>2007-12-06 16:38:32 -0500
commit43ec402bcd6a2333a4e213de3a82d7e3392b0fb0 (patch)
treef0cddbec380d3ba302f63423106fefdec961d623 /Makefile.am
parent7e35135e9ad1ea2ef101402ea26bec62c3cbb69a (diff)
downloadxorg-lib-libXmu-43ec402bcd6a2333a4e213de3a82d7e3392b0fb0.tar.gz
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a4a951d..89ef346 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -10,3 +10,13 @@ EXTRA_DIST = \
xmuu.pc.in \
autogen.sh \
include/X11/Xmu/WhitePoint.h
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog