summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2023-03-26 11:33:06 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2023-03-27 13:58:06 -0700
commitb08c297a37c2b061de783b1954bb908796fe91b0 (patch)
treed2a982fc0aa14d79f5aa3b35367940989b4105a3 /test/Makefile.am
parentf3d7d1f96fba76c275df990b97d4c0995a70ee4b (diff)
downloadxorg-lib-libXmu-b08c297a37c2b061de783b1954bb908796fe91b0.tar.gz
test: Add simple test cases for functions in src/RdBitF.c
Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index 6a1dbbf..5af50d1 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -30,7 +30,7 @@ AM_CFLAGS = $(CWARNFLAGS) $(XMU_CFLAGS) $(GLIB_CFLAGS)
XMU_TEST_LIBS = ${top_builddir}/src/libXmu.la $(XMU_LIBS) $(GLIB_LIBS)
XMUU_TEST_LIBS = ${top_builddir}/src/libXmuu.la $(XMUU_LIBS) $(GLIB_LIBS)
-check_PROGRAMS = EditResStream
+check_PROGRAMS = EditResStream ReadBitmapData
TESTS = $(check_PROGRAMS)
TESTS_ENVIRONMENT = $(MALLOC_DEBUG_ENV)
@@ -44,8 +44,14 @@ LOG_COMPILER = $(srcdir)/tap-test
EditResStream_SOURCES = EditResStream.c
EditResStream_LDADD = $(XMU_TEST_LIBS)
+ReadBitmapData_SOURCES = ReadBitmapData.c
+ReadBitmapData_LDADD = $(XMU_TEST_LIBS)
+
endif HAVE_GLIB
endif ENABLE_UNIT_TESTS
EXTRA_DIST = \
+ bitmaps/plaid \
+ bitmaps/star \
+ bitmaps/xlogo64 \
tap-test