summaryrefslogtreecommitdiff
path: root/sxpm/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2006-11-21 17:12:18 -0800
committerAlan Coopersmith <alan.coopersmith@sun.com>2006-11-21 17:12:18 -0800
commitbcda4f17ab3fa9f0572f876dbeb09b45fbc23f3d (patch)
tree3df47e43929cbf642d86967a91c5b72146e7b4b2 /sxpm/Makefile.am
parent3c881daddcc251d6e806715d267e4e55934abd1a (diff)
downloadxorg-lib-libXpm-xpm-gettext.tar.gz
Sun bug 4486226: Xpm is not internationalizedxpm-gettext
<http://bugs.opensolaris.org/bugdatabase/view_bug.do?bug_id=4486226> Use gettext() to allow translated messages in sxpm & cxpm
Diffstat (limited to 'sxpm/Makefile.am')
-rw-r--r--sxpm/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/sxpm/Makefile.am b/sxpm/Makefile.am
index 1b63cb3..04571de 100644
--- a/sxpm/Makefile.am
+++ b/sxpm/Makefile.am
@@ -42,6 +42,14 @@ SUFFIXES = .$(APP_MAN_SUFFIX) .man
.man.$(APP_MAN_SUFFIX):
sed $(MAN_SUBSTS) < $< > $@
+if USE_GETTEXT
+noinst_DATA = sxpm.po
+
+sxpm.po: $(sxpm_SOURCES)
+ xgettext -c"L10N_Comments" -d sxpm -n $(sxpm_SOURCES)
+
+CLEANFILES += sxpm.po
+endif
endif
EXTRA_DIST = \