summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKevin E Martin <kem@kem.org>2005-11-19 07:15:43 +0000
committerKevin E Martin <kem@kem.org>2005-11-19 07:15:43 +0000
commitbf2fcad15b7bf2c505f5478648bf6ecbc0be701a (patch)
tree039658f14b549dab2ab0cf43e7d65041986588a1 /configure.ac
parenta27c3d61d107fe4af33181a63f8ea951367ff418 (diff)
downloadxorg-lib-libXrandr-bf2fcad15b7bf2c505f5478648bf6ecbc0be701a.tar.gz
Update pkgconfig files to separate library build-time dependencies from
application build-time dependencies, and update package deps to work with separate build roots.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a77d930..1903a98 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,7 +32,7 @@ dnl try to keep these the same. Note that the library has an extra
dnl digit in the version number to track changes which don't affect the
dnl protocol, so Xrandr version l.n.m corresponds to protocol version l.n
dnl
-AC_INIT(libXrandr, 0.99.2, [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], libXrandr)
+AC_INIT(libXrandr, 1.1.0, [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], libXrandr)
AC_CONFIG_AUX_DIR(.)
AM_INIT_AUTOMAKE([dist-bzip2])
AM_MAINTAINER_MODE
@@ -52,7 +52,8 @@ AC_SUBST(X_LIBS)
# find the required protocol version
RANDR_VERSION=[`echo $VERSION | sed 's/^\([0-9][0-9]*\.[0-9][0-9]*\).*$/\1/'`]
-PKG_CHECK_MODULES(RANDR, randrproto >= $RANDR_VERSION xext xrender renderproto)
+AC_SUBST(RANDR_VERSION)
+PKG_CHECK_MODULES(RANDR, randrproto >= $RANDR_VERSION xext xextproto xrender renderproto)
AC_SUBST(RANDR_CFLAGS)
AC_SUBST(RANDR_LIBS)