summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 16:38:43 -0500
committerJames Cloos <cloos@jhcloos.com>2007-12-06 16:38:43 -0500
commite1333b82c0f6e7b9acdbae19d18377a0ed65bddb (patch)
treeb69e26f2421d1d7cb1f50de1c327fba88a1edad7 /Makefile.am
parente10d5cbe4c5ed98ae1856e20a0e9d31321330d53 (diff)
downloadxorg-lib-libXrender-e1333b82c0f6e7b9acdbae19d18377a0ed65bddb.tar.gz
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b0a3a73..c194386 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -28,3 +28,13 @@ pkgconfig_DATA = xrender.pc
EXTRA_DIST = xrender.pc.in autogen.sh
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog