summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2011-03-10 14:23:44 -0800
committerAlan Coopersmith <alan.coopersmith@oracle.com>2011-03-18 19:06:40 -0700
commit4bf003a824577b5a46a59b3b3e91687b530ee48f (patch)
treea5b2fbba15a63612c8f8ca487ea5a37f6063b033 /Makefile.am
parent42c611d9f8c80528f6e36ceb0ce245b06e8b1e8e (diff)
downloadxorg-lib-libXt-4bf003a824577b5a46a59b3b3e91687b530ee48f.tar.gz
Add test framework similar to xserver and use it to test XtAsprintf
Only two simple test cases to start with: - compares the results of snprintf of a short string to a static buffer with the new buffer returned by XtAsprintf. - compare the results of using XtAsprintf to replicate a portion of a very long string with the original string. Uses malloc debugging flags for various platforms to try to catch errors with uninitialized memory (such as the recently fixed failure to terminate the string). Requires xorg-macros 1.13 for XORG_ENABLE_UNIT_TESTS and XORG_WITH_GLIB. Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com> Reviewed-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index e9e0316..8ef09ca 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,7 +19,7 @@
# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
# PERFORMANCE OF THIS SOFTWARE.
-SUBDIRS = util src include man specs
+SUBDIRS = util src include man specs test
ACLOCAL_AMFLAGS = -I m4