summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2009-01-30 18:22:10 -0200
committerPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2009-01-30 18:22:10 -0200
commitf56a69f2cf7df1e7cdf2494c5408786e53467374 (patch)
treec2b4d72f8bd8af0de6efdccd7ae8e3028c654d08 /Makefile.am
parentc1f227f94aec6f4555182965fc0d2d8f33fef01f (diff)
downloadxorg-lib-libXt-f56a69f2cf7df1e7cdf2494c5408786e53467374.tar.gz
Janitor: ansification, make distcheck, compiler warnings, .gitignore.
Most "compiler" warnings were actually sparse warnings, due to assigning a integer to a pointer, or an external symbol without a previous declaration.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 2 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 8409cfb..1d96895 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -21,19 +21,16 @@
SUBDIRS = util src include man
-AM_CFLAGS = $(XT_CFLAGS) -I$(top_srcdir)/include -I$(top_srcdir)/include/X11 -I$(top_builddir)/include/X11
-
-
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = xt.pc
-EXTRA_DIST = xt.pc.in ChangeLog autogen.sh
+EXTRA_DIST = xt.pc.in ChangeLog
MAINTAINERCLEANFILES=ChangeLog
.PHONY: ChangeLog
ChangeLog:
- (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+ $(CHANGELOG_CMD)
dist-hook: ChangeLog