summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThierry Reding <thierry.reding@avionic-design.de>2013-01-03 10:16:55 +0100
committerAlan Coopersmith <alan.coopersmith@oracle.com>2013-06-07 20:58:16 -0700
commit0bf255ce5f2aeacece0b685996491729f804fe94 (patch)
treea7e0e125c19683c31da58f17ef858bfc88abe63d /configure.ac
parent02fd80afd5d2416301e5166e202ff859902c7987 (diff)
downloadxorg-lib-libXt-0bf255ce5f2aeacece0b685996491729f804fe94.tar.gz
Fix cross-compilation
When cross-compiling against a sysroot for instance, a --sysroot option is typically passed via the CPPFLAGS variable. This can cause the build to break in the util subdirectory which requires the CPPFLAGS to be set for the build system. Solve this by using the value of CPPFLAGS_FOR_BUILD for CPPFLAGS in the util subdirectory. Cross-compile setups can override the variable when calling the configure script. Signed-off-by: Thierry Reding <thierry.reding@avionic-design.de> Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3f82427..1f95a5c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,6 +64,8 @@ if test x"$CC_FOR_BUILD" = x; then
fi
fi
AC_SUBST([CC_FOR_BUILD])
+CPPFLAGS_FOR_BUILD=${CPPFLAGS_FOR_BUILD-${CPPFLAGS}}
+AC_SUBST(CPPFLAGS_FOR_BUILD)
CFLAGS_FOR_BUILD=${CFLAGS_FOR_BUILD-${CFLAGS}}
AC_SUBST(CFLAGS_FOR_BUILD)
LDFLAGS_FOR_BUILD=${LDFLAGS_FOR_BUILD-${LDFLAGS}}