summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <Alan.Coopersmith@sun.com>2005-10-18 01:50:02 +0000
committerAlan Coopersmith <Alan.Coopersmith@sun.com>2005-10-18 01:50:02 +0000
commit5e37faddaac8ac50ee4ca719975f9bf526e4c980 (patch)
tree4feb3a00af6cbee8174bc5aaadbbcc35517e2ec8 /configure.ac
parent52edad6913e3efd3fcec6c73e13d33bf8c3a5e65 (diff)
downloadxorg-lib-libXt-5e37faddaac8ac50ee4ca719975f9bf526e4c980.tar.gz
Add --with-xfile-search-path=<path> and default setting to match monolith
XFileSearchPathDefault in Imake (including extra directories used in Debian section of linux.cf.)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2d9c6dc..ab3e369 100644
--- a/configure.ac
+++ b/configure.ac
@@ -55,6 +55,15 @@ if test "x$XKB" = "xyes" ; then
AC_DEFINE(XKB, 1, [Define to 1 to use XKB for keysym resolution.])
fi
+# Replaces XFileSearchPathDefault from Imake configs
+XFILESEARCHPATHDEFAULT='$(sysconfdir)/X11/%L/%T/%N%C%S:$(sysconfdir)/X11/%l/%T/%N%C%S:$(sysconfdir)/X11/%T/%N%C%S:$(sysconfdir)/X11/%L/%T/%N%S:$(sysconfdir)/X11/%l/%T/%N%S:$(sysconfdir)/X11/%T/%N%S:$(libdir)/X11/%L/%T/%N%C%S:$(libdir)/X11/%l/%T/%N%C%S:$(libdir)/X11/%T/%N%C%S:$(libdir)/X11/%L/%T/%N%S:$(libdir)/X11/%l/%T/%N%S:$(libdir)/X11/%T/%N%S'
+
+AC_ARG_WITH(xfile-search-path,
+ AC_HELP_STRING([--with-xfile-search-path=<path>],
+ [Set path to search for app-defaults and other files]),
+ [XFILESEARCHPATHDEFAULT="$withval"], [])
+AC_SUBST([XFILESEARCHPATHDEFAULT])
+
# Replacement for Imake ToolkitStringsABIOptions, controls string tables
# generated by util/string.list in StringDefs.h & Shell.h
case $host_os in