summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-05-18 15:38:31 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-05-18 15:38:31 +0000
commit605a76dcc93e277e1b26841a0225b7e0fb851b76 (patch)
tree4d5910a2810d892fb26d85977071bacea22c9969 /configure.ac
parentb0a241cf7c7ab3840929da3b1aabdda7bab22517 (diff)
downloadxorg-lib-libXt-605a76dcc93e277e1b26841a0225b7e0fb851b76.tar.gz
- conditionally include config.h in xc/lib/Xt sourcesXORG-6_8_99_8
- add build system for lib/Xt
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac50
1 files changed, 50 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..84b43e1
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,50 @@
+dnl
+dnl $Id$
+dnl
+dnl Copyright © 2003 Keith Packard, Noah Levitt
+dnl
+dnl Permission to use, copy, modify, distribute, and sell this software and its
+dnl documentation for any purpose is hereby granted without fee, provided that
+dnl the above copyright notice appear in all copies and that both that
+dnl copyright notice and this permission notice appear in supporting
+dnl documentation, and that the name of Keith Packard not be used in
+dnl advertising or publicity pertaining to distribution of the software without
+dnl specific, written prior permission. Keith Packard makes no
+dnl representations about the suitability of this software for any purpose. It
+dnl is provided "as is" without express or implied warranty.
+dnl
+dnl KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+dnl INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+dnl EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+dnl CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+dnl DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+dnl TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+dnl PERFORMANCE OF THIS SOFTWARE.
+dnl
+dnl Process this file with autoconf to create configure.
+
+AC_PREREQ([2.57])
+
+dnl
+dnl
+AC_INIT(libXt, 0.1.5, [keithp@keithp.com], libXt)
+AM_INIT_AUTOMAKE([dist-bzip2])
+AM_MAINTAINER_MODE
+
+AM_CONFIG_HEADER(config.h)
+
+# Check for progs
+AC_PROG_CC
+AC_PROG_LIBTOOL
+
+PKG_CHECK_MODULES(XT, sm x11 xproto)
+
+# Check render configuration, strip extra digits from package version to
+# find the required protocol version
+
+AC_OUTPUT([Makefile
+ src/Makefile
+ util/Makefile
+ include/Makefile
+ man/Makefile
+ xt.pc])