summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas E. Dickey <dickey@invisible-island.net>2019-04-16 21:13:57 -0400
committerThomas E. Dickey <dickey@invisible-island.net>2019-04-16 21:25:18 -0400
commit735ee4b6cc90c9ebfc33680c820c299545aa02ed (patch)
tree30ee9baa1790702fd0dfe4c93e4ec6f82d43d06c /configure.ac
parentf2418d6ff43197d7e51404aa13ca9cb2434669ff (diff)
downloadxorg-lib-libXt-735ee4b6cc90c9ebfc33680c820c299545aa02ed.tar.gz
Add --disable-const and --enable-geo-tattler options for new/updated features.
Also, show configure choices for build-logs. Signed-off-by: Thomas E. Dickey <dickey@invisible-island.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac57
1 files changed, 42 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 53b2178..9c44694 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,5 @@
#
+# Copyright © 2019 Thomas Dickey
# Copyright © 2003 Keith Packard, Noah Levitt
#
# Permission to use, copy, modify, distribute, and sell this software and its
@@ -23,7 +24,7 @@
# Initialize Autoconf
AC_PREREQ([2.60])
AC_INIT([libXt], [1.1.5],
- [https://gitlab.freedesktop.org/xorg/lib/libXt/issues], [libXt])
+ [https://gitlab.freedesktop.org/xorg/lib/libXt/issues], [libXt])
AC_CONFIG_SRCDIR([Makefile.am])
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_MACRO_DIR([m4])
@@ -36,7 +37,7 @@ AC_PROG_LIBTOOL
# Require X.Org macros 1.13 or later for XORG_ENABLE_UNIT_TESTS
m4_ifndef([XORG_MACROS_VERSION],
- [m4_fatal([must install xorg-macros 1.13 or later before running autoconf/autogen])])
+ [m4_fatal([must install xorg-macros 1.13 or later before running autoconf/autogen])])
XORG_MACROS_VERSION(1.13)
XORG_DEFAULT_OPTIONS
XORG_CHECK_MALLOC_ZERO
@@ -60,7 +61,7 @@ if test x"$CC_FOR_BUILD" = x; then
if test x"$cross_compiling" = xyes; then
AC_CHECK_PROGS(CC_FOR_BUILD, gcc cc)
else
- CC_FOR_BUILD="$CC"
+ CC_FOR_BUILD="$CC"
fi
fi
AC_SUBST([CC_FOR_BUILD])
@@ -109,54 +110,79 @@ case $host_os in
esac
# Options
+AC_MSG_CHECKING(if XKB support is wanted)
AC_ARG_ENABLE(xkb, AS_HELP_STRING([--disable-xkb], [Disable XKB support]),
XKB="$enableval", XKB="yes")
+AC_MSG_RESULT($XKB)
if test "x$XKB" = "xyes" ; then
AC_DEFINE(XKB, 1, [Define to 1 to use XKB for keysym resolution.])
fi
+AC_MSG_CHECKING(if C const-support is wanted)
+AC_ARG_ENABLE(const, AS_HELP_STRING([--disable-const], [Disable const-support]),
+ USE_CONST="$enableval", USE_CONST="yes")
+AC_MSG_RESULT($USE_CONST)
+if test "x$USE_CONST" = "xyes" ; then
+ AC_DEFINE(_CONST_X_STRING, 1, [Define to 1 to use standard C const feature.])
+fi
+
+AC_MSG_CHECKING(if geo-tattler traces are wanted)
+AC_ARG_ENABLE(geo-tattler, AS_HELP_STRING([--enable-geo-tattler], [Enable geo-tattler traces]),
+ GEO_TATTLER="$enableval", GEO_TATTLER="no")
+AC_MSG_RESULT($GEO_TATTLER)
+if test "x$GEO_TATTLER" = "xyes" ; then
+ AC_DEFINE(XT_GEO_TATTLER, 1, [Define to 1 to use standard C const feature.])
+fi
+
# --enable-unit-tests
XORG_ENABLE_UNIT_TESTS
XORG_WITH_GLIB([2.16])
# Memory checking support
case $host_os in
- solaris*)
- AC_CHECK_LIB([umem], [umem_alloc],
- [MALLOC_DEBUG_ENV='LD_PRELOAD=libumem.so UMEM_DEBUG=default'])
- ;;
- *-gnu*) # GNU libc - Value is used as a single byte bit pattern,
- # both directly and inverted, so should not be 0 or 255.
- MALLOC_DEBUG_ENV='MALLOC_PERTURB_=15'
- ;;
- *bsd*|darwin*)
- MALLOC_DEBUG_ENV='MallocPreScribble=1 MallocScribble=1'
- ;;
+ solaris*)
+ AC_CHECK_LIB([umem], [umem_alloc],
+ [MALLOC_DEBUG_ENV='LD_PRELOAD=libumem.so UMEM_DEBUG=default'])
+ ;;
+ *-gnu*) # GNU libc - Value is used as a single byte bit pattern,
+ # both directly and inverted, so should not be 0 or 255.
+ MALLOC_DEBUG_ENV='MALLOC_PERTURB_=15'
+ ;;
+ *bsd*|darwin*)
+ MALLOC_DEBUG_ENV='MallocPreScribble=1 MallocScribble=1'
+ ;;
esac
+AC_MSG_CHECKING(for definitions to enable memory-checking support)
+AC_MSG_RESULT(${MALLOC_DEBUG_ENV:-none})
AC_SUBST([MALLOC_DEBUG_ENV])
# Replaces XFileSearchPathDefault from Imake configs
XFILESEARCHPATHDEFAULT='$(sysconfdir)/X11/%L/%T/%N%C%S:$(sysconfdir)/X11/%l/%T/%N%C%S:$(sysconfdir)/X11/%T/%N%C%S:$(sysconfdir)/X11/%L/%T/%N%S:$(sysconfdir)/X11/%l/%T/%N%S:$(sysconfdir)/X11/%T/%N%S:$(datadir)/X11/%L/%T/%N%C%S:$(datadir)/X11/%l/%T/%N%C%S:$(datadir)/X11/%T/%N%C%S:$(datadir)/X11/%L/%T/%N%S:$(datadir)/X11/%l/%T/%N%S:$(datadir)/X11/%T/%N%S:$(libdir)/X11/%L/%T/%N%C%S:$(libdir)/X11/%l/%T/%N%C%S:$(libdir)/X11/%T/%N%C%S:$(libdir)/X11/%L/%T/%N%S:$(libdir)/X11/%l/%T/%N%S:$(libdir)/X11/%T/%N%S'
+AC_MSG_CHECKING(for X files search path)
AC_ARG_WITH(xfile-search-path,
AS_HELP_STRING([--with-xfile-search-path=<path>],
[Set path to search for app-defaults and other files]),
[XFILESEARCHPATHDEFAULT="$withval"], [])
+AC_MSG_RESULT(${XFILESEARCHPATHDEFAULT:-none})
AC_SUBST([XFILESEARCHPATHDEFAULT])
+AC_MSG_CHECKING(for X app-defaults directory)
AC_ARG_WITH(appdefaultdir,
AS_HELP_STRING([--with-appdefaultdir=<path>],
[Set app-default directory (default: ${datadir}/X11/app-defaults)]),
[appdefaultdir="$withval"],
[appdefaultdir=${datadir}/X11/app-defaults])
+AC_MSG_RESULT($appdefaultdir)
AX_DEFINE_DIR([appdefaultdir], [appdefaultdir], [app default data directory])
# Replacement for Imake ToolkitStringsABIOptions, controls string tables
# generated by util/string.list in StringDefs.h & Shell.h
+AC_MSG_CHECKING(for ABI options)
case $host_os in
solaris*)
# Solaris uses -intelabi even on SPARC
- STRINGSABIOPTIONS="-intelabi -solarisabinames"
+ STRINGSABIOPTIONS="-intelabi -solarisabinames"
;;
sco* | svr4*)
case $host_cpu in
@@ -165,6 +191,7 @@ case $host_os in
esac
;;
esac
+AC_MSG_RESULT(${STRINGSABIOPTIONS:-none})
AC_SUBST(STRINGSABIOPTIONS)
ERRORDBDIR=${datadir}/X11