summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas E. Dickey <dickey@invisible-island.net>2019-05-06 19:35:36 -0400
committerThomas E. Dickey <dickey@invisible-island.net>2019-05-06 19:35:36 -0400
commitf0ff9ea4fc653d27db3251a5bae97df4b963b1ba (patch)
tree6881d5b5524bda7a6a76062ec6862cac69bd8829 /configure.ac
parent27778fd000d417dd81b940fc8a7855d4b4ccd068 (diff)
downloadxorg-lib-libXt-f0ff9ea4fc653d27db3251a5bae97df4b963b1ba.tar.gz
Add related fix from
https://gitlab.freedesktop.org/xorg/lib/libxt/issues/6 https://bugs.chromium.org/p/chromium/issues/detail?id=284595 Signed-off-by: Thomas E. Dickey <dickey@invisible-island.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 7cc9294..ba40716 100644
--- a/configure.ac
+++ b/configure.ac
@@ -64,6 +64,10 @@ if test x"$CC_FOR_BUILD" = x; then
CC_FOR_BUILD="$CC"
fi
fi
+if test x"$cross_compiling" != xyes; then
+ : ${CFLAGS_FOR_BUILD=${CFLAGS}}
+ : ${LDFLAGS_FOR_BUILD=${LDFLAGS}}
+fi
AC_SUBST([CC_FOR_BUILD])
DEFAULT_CPPFLAGS_FOR_BUILD="${CPPFLAGS}"
AC_CHECK_FUNC(asprintf,
@@ -71,9 +75,7 @@ AC_CHECK_FUNC(asprintf,
CPPFLAGS_FOR_BUILD=${CPPFLAGS_FOR_BUILD-${DEFAULT_CPPFLAGS_FOR_BUILD}}
AC_SUBST(CPPFLAGS_FOR_BUILD)
DEFAULT_CFLAGS_FOR_BUILD="${CFLAGS} ${CWARNFLAGS}"
-CFLAGS_FOR_BUILD=${CFLAGS_FOR_BUILD-${DEFAULT_CFLAGS_FOR_BUILD}}
AC_SUBST(CFLAGS_FOR_BUILD)
-LDFLAGS_FOR_BUILD=${LDFLAGS_FOR_BUILD-${LDFLAGS}}
AC_SUBST(LDFLAGS_FOR_BUILD)
# Map function checks to old Imake #defines