summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-06-06 18:41:36 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-06-06 18:41:36 -0700
commit8bbc3b75318c67f6089d50f68d53d092390c8233 (patch)
treef4d2dda3e78dc9796c5dccd151528d485cd96101 /Makefile.am
parent6aaa875dffbcc5dd2206644cfa73fdfd8ffe280f (diff)
downloadxorg-lib-libXtst-8bbc3b75318c67f6089d50f68d53d092390c8233.tar.gz
Replace static ChangeLog with dist-hook to generate from git
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ec888f5..0a994aa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,7 +24,13 @@ SUBDIRS = src man
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = xtst.pc
-EXTRA_DIST = xtst.pc.in autogen.sh
+EXTRA_DIST = xtst.pc.in autogen.sh ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog
if LINT
lint: