summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2013-04-13 11:05:27 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2013-04-13 11:05:27 -0700
commit46ed6283034b5b7d14584009453f5d974cfacf1e (patch)
tree978ba7fc4c7e9c4070a6be3a8dfc1cef8809707b /configure.ac
parent2aafac9474a0a0a0c39797862f823255918cf368 (diff)
downloadxorg-lib-libXtst-46ed6283034b5b7d14584009453f5d974cfacf1e.tar.gz
Use _XEatDataWords to eat data in error cases
Avoids having to do calculcations based on response contents Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7ef0153..d83d4d8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -47,6 +47,12 @@ XORG_CHECK_SGML_DOCTOOLS(1.8)
# Obtain compiler/linker options for depedencies
PKG_CHECK_MODULES(XTST, x11 [xext >= 1.0.99.4] xi [recordproto >= 1.13.99.1] [xextproto >= 7.0.99.3] inputproto)
+# Check for _XEatDataWords function that may be patched into older Xlib release
+SAVE_LIBS="$LIBS"
+LIBS="$XTST_LIBS"
+AC_CHECK_FUNCS([_XEatDataWords])
+LIBS="$SAVE_LIBS"
+
# Determine if the source for man pages is available
# It may already be present (tarball) or can be generated using xmlto
AM_CONDITIONAL([INSTALL_MANPAGES],