summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-06-06 14:11:04 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-06-06 14:11:04 -0700
commit57a201a15637cfea6c15a4d0ed8b629c9cd49495 (patch)
tree63f4dbcc97d2aee0823ddcf0f1abc6187668ccfc /configure.ac
parent5e791a1465aba3b8be89b4cf2d9f90dee18e8e96 (diff)
downloadxorg-lib-libXtst-57a201a15637cfea6c15a4d0ed8b629c9cd49495.tar.gz
Add hooks to check code with sparse/lint
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a7fc7ae..554ab13 100644
--- a/configure.ac
+++ b/configure.ac
@@ -36,6 +36,11 @@ AC_PROG_LIBTOOL
# Check for dependencies
PKG_CHECK_MODULES(XTST, x11 xext recordproto xextproto inputproto)
+dnl Allow checking code with lint, sparse, etc.
+XORG_WITH_LINT
+XORG_LINT_LIBRARY([Xtst])
+LINT_FLAGS="${LINT_FLAGS} ${XTST_CFLAGS}"
+
AC_SUBST(XTST_CFLAGS)
AC_SUBST(XTST_LIBS)