summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2010-01-23 10:49:06 -0500
committerGaetan Nadon <memsize@videotron.ca>2010-01-24 07:55:44 -0500
commita125ac058be77d81c1806420a7fd1df3b19a6bf4 (patch)
tree3c4462c80aef201b4e78309c750b7f425dd09a2a /configure.ac
parent1b887152b514c1701e09313dde718fb9e263ff9f (diff)
downloadxorg-lib-libXtst-a125ac058be77d81c1806420a7fd1df3b19a6bf4.tar.gz
man: allow installing prebuilt man pages from tarball
The man pages source may be supplied in the tarball or built from git. The makefile needs to take that into consideration and adjust the targets accordingly. Reviewed-by: Dan Nicholson <dbn.lists@gmail.com> Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2c898e8..375745e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,6 +45,11 @@ XTST_CFLAGS="$CWARNFLAGS $XTST_CFLAGS"
AC_SUBST(XTST_CFLAGS)
AC_SUBST(XTST_LIBS)
+# Determine if the source for man pages is available
+# It may already be present (tarball) or can be generated using xmlto
+AM_CONDITIONAL([INSTALL_MANPAGES],
+ [test -f "$srcdir/man/XTestQueryExtension.man" || test "x$have_xmlto" = xyes])
+
dnl Allow checking code with lint, sparse, etc.
XORG_WITH_LINT
XORG_LINT_LIBRARY([Xtst])