summaryrefslogtreecommitdiff
path: root/scanpci/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2018-09-19 16:15:41 -0700
committerDylan Baker <dylan@pnwbakers.com>2020-11-02 08:00:48 -0800
commit89fcd717a60e7a6440b56ff7c82b5eeb80b92a2f (patch)
treeb85f1cbc42b2cb7119ff999c591f379336dd3782 /scanpci/meson.build
parent1ebcfe918a0da46a5b7ab44fc3ec0e6c65f98043 (diff)
downloadxorg-lib-libpciaccess-89fcd717a60e7a6440b56ff7c82b5eeb80b92a2f.tar.gz
Add a meson build system
I believe this is correct and complete, but I could have missed something on non-linux OSes. Reviewed-by: Eric Anholt <eric@anholt.net>
Diffstat (limited to 'scanpci/meson.build')
-rw-r--r--scanpci/meson.build25
1 files changed, 25 insertions, 0 deletions
diff --git a/scanpci/meson.build b/scanpci/meson.build
new file mode 100644
index 0000000..6ae1d6a
--- /dev/null
+++ b/scanpci/meson.build
@@ -0,0 +1,25 @@
+# Copyright © 2018-2020 Intel Corporation
+
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+
+scanpci = executable(
+ 'scanpci',
+ 'scanpci.c',
+ dependencies : [dep_pciaccess],
+)