summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2009-03-27 06:55:32 -0700
committerDan Nicholson <dbn.lists@gmail.com>2009-03-27 06:55:32 -0700
commit0c1bbb05d975cf7b3411259900500cc122fc136b (patch)
tree6e5c9c6adf8674c48da18c55993b530e69fac5fa /configure.ac
parentf4d8e2932cdd60653d2f762ad7502e6ec5710fe5 (diff)
downloadxorg-lib-libxkbcommon-0c1bbb05d975cf7b3411259900500cc122fc136b.tar.gz
Import xkbcomp sources for CompileKeymap
A copy of the xkbcomp sources (except the frontend) have been copied in to provide a means to compile a XkbDescPtr. This definitely doesn't build or do the right thing yet.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 18 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 652fbf4..03b7502 100644
--- a/configure.ac
+++ b/configure.ac
@@ -29,6 +29,7 @@ AC_CONFIG_HEADERS([src/config.h])
AC_PROG_LIBTOOL
AC_PROG_CC
+AC_PROG_YACC
m4_ifndef([PKG_PROG_PKG_CONFIG],
[m4_fatal([Could not locate the pkg-config autoconf macros.
@@ -38,6 +39,11 @@ m4_ifndef([PKG_PROG_PKG_CONFIG],
autoreconf/autogen.sh.])])
PKG_PROG_PKG_CONFIG
+# Require xorg-macros version 1.2.0 or newer for XORG_CHANGELOG macro
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros before running autoconf/autogen.sh])])
+XORG_MACROS_VERSION([1.2.0])
+
dnl Build native compiler needed for makekeys
AC_ARG_VAR([CC_FOR_BUILD], [Build native C compiler program])
if test "x$CC_FOR_BUILD" = x; then
@@ -48,6 +54,10 @@ if test "x$CC_FOR_BUILD" = x; then
fi
fi
+AC_CHECK_FUNCS([strdup strcasecmp])
+XORG_CHECK_MALLOC_ZERO
+XORG_CWARNFLAGS
+
PKG_CHECK_MODULES([X11], [xproto kbproto >= 1.0.99.1])
dnl Ensure we have keysym headers
@@ -69,13 +79,14 @@ AC_SUBST([XF86KEYSYM_H])
AC_SUBST([KS_HEADERS], ['$(KEYSYMDEF_H) $(XF86KEYSYM_H)'])
-# Require xorg-macros version 1.2.0 or newer for XORG_CHANGELOG macro
-m4_ifndef([XORG_MACROS_VERSION],
- [m4_fatal([must install xorg-macros before running autoconf/autogen.sh])])
-XORG_MACROS_VERSION([1.2.0])
+AC_ARG_WITH([xkb_config_root],
+ [AC_HELP_STRING([--with-xkb-config-root=<paths>],
+ [Set default XKB config root (default: ${datadir}/X11/xkb)])],
+ [XKBCONFIGROOT="$withval"],
+ [XKBCONFIGROOT='${datadir}/X11/xkb'])
+AC_SUBST([XKBCONFIGROOT])
+
XORG_RELEASE_VERSION
-XORG_CHECK_MALLOC_ZERO
-XORG_CWARNFLAGS
XORG_CHANGELOG
AC_OUTPUT([
@@ -83,5 +94,6 @@ Makefile
include/Makefile
src/Makefile
src/makekeys/Makefile
+src/xkbcomp/Makefile
test/Makefile
])