summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2009-01-14 18:00:10 -0800
committerDan Nicholson <dbn.lists@gmail.com>2009-03-19 11:51:09 -0700
commitfa6a3d122d57b3ae89076741ec90ec8c1b78ce6b (patch)
treec88cf2d537a677fbccff3dfcf86016c8ad856138 /configure.ac
parent7f64541c30e66f4fb172420a1107b73abf5a3020 (diff)
downloadxorg-lib-libxkbcommon-fa6a3d122d57b3ae89076741ec90ec8c1b78ce6b.tar.gz
Generate keysym tables from X and XF86 keysym definitions
The keysym hash table ks_tables.h is generated by makekeys from keysymdef.h and XF86keysym.h.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 90eec9e..d0f1735 100644
--- a/configure.ac
+++ b/configure.ac
@@ -49,6 +49,23 @@ fi
PKG_CHECK_MODULES([X11], [xproto])
+dnl Ensure we have keysym headers
+AC_MSG_CHECKING([for X11 includedir])
+x11includedir="`$PKG_CONFIG --variable=includedir xproto`/X11"
+AC_MSG_RESULT([$x11includedir])
+
+AC_MSG_CHECKING([for keysymdef.h])
+KEYSYMDEF_H="$x11includedir/keysymdef.h"
+test -f "$KEYSYMDEF_H" || AC_MSG_ERROR([can't locate keysymdef.h in $x11includedir])
+AC_MSG_RESULT([$KEYSYMDEF_H])
+AC_SUBST([KEYSYMDEF_H])
+
+AC_MSG_CHECKING([for XF86keysym.h])
+XF86KEYSYM_H="$x11includedir/XF86keysym.h"
+test -f "$XF86KEYSYM_H" || AC_MSG_ERROR([can't locate XF86keysym.h in $x11includedir])
+AC_MSG_RESULT([$XF86KEYSYM_H])
+AC_SUBST([XF86KEYSYM_H])
+
# Require xorg-macros version 1.2.0 or newer for XORG_CHANGELOG macro
m4_ifndef([XORG_MACROS_VERSION],
[m4_fatal([must install xorg-macros before running autoconf/autogen.sh])])