summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2020-09-07 19:24:12 +1000
committerRan Benita <ran@unusedvar.com>2020-09-07 22:01:57 +0300
commit13745014c384aca9606dbda5364b6c7ea49e2471 (patch)
treefaf83f32ca5925b91fc587fbc823bbd0eda1eb7b /meson.build
parent534e54f6210bb14a3a67cdc396714d09af61a227 (diff)
downloadxorg-lib-libxkbcommon-13745014c384aca9606dbda5364b6c7ea49e2471.tar.gz
test: include unstd.h in the registry test to cut down the MacOS warnings
mkdtmp, rmdir and unlink are in unstd.h on MacOS. Since including that it doesn't hurt us on Linux, let's do it without ifdefs. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 046fc54..79acda4 100644
--- a/meson.build
+++ b/meson.build
@@ -89,6 +89,9 @@ if get_option('default-options') != ''
else
configh_data.set('DEFAULT_XKB_OPTIONS', 'NULL')
endif
+if cc.has_header('unistd.h')
+ configh_data.set('HAVE_UNISTD_H', 1)
+endif
if cc.links('int main(){if(__builtin_expect(1<0,0)){}}', name: '__builtin_expect')
configh_data.set('HAVE___BUILTIN_EXPECT', 1)
endif