summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2020-09-03 08:30:45 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2020-09-03 18:14:16 +1000
commit66e7f0da20601c535066f1ceb83a1043db3ad1d0 (patch)
tree1be01fff282c6cd3d4ed1662f04a69c5dfd11b25 /meson.build
parent4d0d509129e5f80c4a9efe4523fc4b0aea58622b (diff)
downloadxorg-lib-libxkbcommon-66e7f0da20601c535066f1ceb83a1043db3ad1d0.tar.gz
Revert: tools: add xkbcli-scaffold-new-layout as helper tool
While this tool is useful for users starting with a new keyboard layout, it is a somewhat bad fit for libxkbcommon. It's the only python tool, we don't even install it yet (because we're not sure yet what it's supposed to do) and there's a potential for it to expand into more corner cases. The only tie it has to libxkbcommon is that it templates the data files that libxkbcommon reads, but those files are effectively public API. Let's remove this tool from there and instead move it to a separate git repository where it can go its own way. This reverts commit d00cf64dbc586a1052e1f0d0e7f1a48bbff293ec
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 0 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index e9233b4..c23e92e 100644
--- a/meson.build
+++ b/meson.build
@@ -652,13 +652,6 @@ You can disable the Wayland xkbcli programs with -Denable-wayland=false.''')
install_man('tools/xkbcli-list.1')
endif
- config_scaffold = configuration_data()
- config_scaffold.set('XKBEXTRAPATH', XKBCONFIGEXTRAPATH)
- config_scaffold.set('DEFAULT_XKB_RULES', get_option('default-rules'))
- configure_file(input: 'tools/xkbcli-scaffold-new-layout.py',
- output: 'xkbcli-scaffold-new-layout',
- configuration: config_scaffold)
-
test('tool-option-parsing',
find_program('test/tool-option-parsing.py'),
env: test_env,