summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorRan Benita <ran@unusedvar.com>2020-08-08 14:35:36 +0300
committerRan Benita <ran@unusedvar.com>2020-08-08 14:43:09 +0300
commita0c1c2f42dafecbad7b9912dcaba7f206805981d (patch)
tree7e3b0a20f5c1bd9943edd5cf4516750a94fd179f /meson.build
parent9b9c5f209433a38c1c2719efa67064503461a722 (diff)
downloadxorg-lib-libxkbcommon-a0c1c2f42dafecbad7b9912dcaba7f206805981d.tar.gz
build: fix byacc invocation
Fixes: https://github.com/xkbcommon/libxkbcommon/issues/133#issuecomment-670902025 Reported-by: Edward-0 Signed-off-by: Ran Benita <ran@unusedvar.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index a4b0f7b..e7d75aa 100644
--- a/meson.build
+++ b/meson.build
@@ -145,7 +145,7 @@ if bison.found()
yacc_gen = generator(
bison,
output: ['@BASENAME@.c', '@BASENAME@.h'],
- arguments: ['@INPUT@', '--defines=@OUTPUT1@', '--output=@OUTPUT0@', '-p _xkbcommon_'],
+ arguments: ['--defines=@OUTPUT1@', '-o', '@OUTPUT0@', '-p', '_xkbcommon_', '@INPUT@'],
)
else
byacc = find_program('byacc', required: false)
@@ -153,7 +153,7 @@ else
yacc_gen = generator(
byacc,
output: ['@BASENAME@.c', '@BASENAME@.h'],
- arguments: ['@INPUT@', '-H', '@OUTPUT1@', '-o', '@OUTPUT0@', '-p _xkbcommon_'],
+ arguments: ['-H', '@OUTPUT1@', '-o', '@OUTPUT0@', '-p', '_xkbcommon_', '@INPUT@'],
)
else
error('Could not find a compatible YACC program (bison or byacc)')