summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2020-07-10 08:50:02 +1000
committerRan Benita <ran@unusedvar.com>2020-08-30 21:49:41 +0300
commitd7b39f6ffbe9b46181c5597b0d0e7373eb2e9070 (patch)
tree9cc4b5e240b5532c822a5f9106a983a3a8d84425 /meson.build
parent05d6efc41723601d4d38e0c43129d2ab9d53fa48 (diff)
downloadxorg-lib-libxkbcommon-d7b39f6ffbe9b46181c5597b0d0e7373eb2e9070.tar.gz
Add /etc/xkb as extra lookup path for system data files
This completes the usual triplet of configuration locations available for most processes: - vendor-provided data files in /usr/share/X11/xkb - system-specific data files in /etc/xkb - user-specific data files in $XDG_CONFIG_HOME/xkb The default lookup order user, system, vendor, just like everything else that uses these conventions. For include directives in rules files, the '%E' resolves to that path. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index e7d75aa..c08b40b 100644
--- a/meson.build
+++ b/meson.build
@@ -47,6 +47,10 @@ if XKBCONFIGROOT == ''
endif
endif
+XKBCONFIGEXTRAPATH = get_option('xkb-config-extra-path')
+if XKBCONFIGEXTRAPATH == ''
+ XKBCONFIGEXTRAPATH = join_paths(get_option('prefix'), get_option('sysconfdir'), 'xkb')
+endif
# The X locale directory for compose.
XLOCALEDIR = get_option('x-locale-root')
@@ -70,6 +74,7 @@ endif
configh_data.set(system_extensions, 1)
system_ext_define = '#define ' + system_extensions
configh_data.set_quoted('DFLT_XKB_CONFIG_ROOT', XKBCONFIGROOT)
+configh_data.set_quoted('DFLT_XKB_CONFIG_EXTRA_PATH', XKBCONFIGEXTRAPATH)
configh_data.set_quoted('XLOCALEDIR', XLOCALEDIR)
configh_data.set_quoted('DEFAULT_XKB_RULES', get_option('default-rules'))
configh_data.set_quoted('DEFAULT_XKB_MODEL', get_option('default-model'))