summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2019-03-29 19:02:51 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2019-03-29 19:02:51 -0700
commit2d017a68e12acf2463edc9cfbdae0aea3ce477b1 (patch)
tree377cfa60a2a2a4a405b3b26e6157b03833f92c0b /configure.ac
parent261992d42905f209cd5bf6afcf8a7ae3aa30b3ff (diff)
downloadxorg-lib-libxkbfile-2d017a68e12acf2463edc9cfbdae0aea3ce477b1.tar.gz
Use strndup if available to avoid -Wstringop-overflow warning from gcc 9
Reported in https://gitlab.freedesktop.org/xorg/lib/libxkbfile/issues/5 Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 86b7833..9611b8c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -40,6 +40,7 @@ XORG_MACROS_VERSION(1.8)
XORG_DEFAULT_OPTIONS
# Checks for library functions.
+AC_CHECK_FUNCS([strndup])
AC_CHECK_FUNC(strcasecmp, [], AC_DEFINE([NEED_STRCASECMP], 1,
[Do not have 'strcasecmp'.]))
AC_CHECK_FUNC(getc_unlocked, AC_DEFINE([HAVE_UNLOCKED_STDIO], 1,