summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2006-08-23 19:14:35 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2006-08-23 19:14:35 -0700
commit3d5e7dd18c8836065c4835740211c10747b18abd (patch)
treea11707949917e70f5c79b3bf46d71b90465ee449 /Makefile.am
parent92807fe90aad2303cec4b54bec40ce6edf671654 (diff)
downloadxorg-lib-libxtrans-3d5e7dd18c8836065c4835740211c10747b18abd.tar.gz
Replace static ChangeLog with dist-hook to generate from git-log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8bbe84c..7b1badc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,3 +18,10 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = xtrans.pc
EXTRA_DIST = xtrans.pc.in ${aclocal_DATA}
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ GIT_DIR=${srcdir}/.git git-log > ChangeLog
+
+dist-hook: ChangeLog