summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2010-01-29 15:05:37 -0500
committerGaetan Nadon <memsize@videotron.ca>2010-02-05 13:23:17 -0500
commitb531ff3ed2ad841b716ba370fd43bbe8f06f1185 (patch)
treefa69505b6666759bd09d94be1a015c1796f4905d /Makefile.am
parent5922556f408fbcd14e7ad23bbe46db2ae8dcdee6 (diff)
downloadxorg-lib-libxtrans-b531ff3ed2ad841b716ba370fd43bbe8f06f1185.tar.gz
doc: use new macros XORG_WITH_GROFF and PS2PDF
These control the usage of doc tools Also use XORG_ENABLE_DOCS to control generation of docs Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index af68a7a..a824f02 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -32,13 +32,15 @@ dist-hook: ChangeLog INSTALL
# Rules to convert documentation from troff to other formats
doc_sources = Xtrans.mm
+if ENABLE_DOCS
+if HAVE_GROFF
+
if HAVE_PS2PDF
printable_format = .pdf
else
printable_format = .ps
endif
-if BUILD_DOCS
doc_DATA = $(doc_sources:.mm=.txt) \
$(doc_sources:.mm=$(printable_format)) \
$(doc_sources:.mm=.html)
@@ -69,4 +71,5 @@ SUFFIXES = .mm .ps .txt .html .pdf
.ps.pdf:
$(AM_V_GEN) $(PS2PDF) $< $@
-endif BUILD_DOCS
+endif HAVE_GROFF
+endif ENABLE_DOCS