summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2009-10-17 13:06:26 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2009-10-17 13:06:26 -0700
commit628b125ff9c72ec93090005b06228690f0dd6004 (patch)
tree223ad84ffcd23432e441be1a7aec79a145e95e1a /configure.ac
parent3b0fc7a5a6d4b4b6903a9ad6685e2441f9fe83a7 (diff)
downloadxorg-lib-libxtrans-628b125ff9c72ec93090005b06228690f0dd6004.tar.gz
Move Xtrans interface docs from xorg-docs module
Only built/installed if --enable-docs is requested, since few people should be writing code using xtrans interfaces directly. Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8bbaf2e..44cf345 100644
--- a/configure.ac
+++ b/configure.ac
@@ -49,5 +49,21 @@ sticky_bit_define="-DHAS_STICKY_DIR_BIT"
AC_SUBST(sticky_bit_define)
+# Documentation is currently provided in troff format, built on request
+AC_PATH_PROGS([GROFF], [groff], [none], [$PATH:/usr/gnu/bin])
+AC_PATH_PROGS([PS2PDF], [ps2pdf], [none], [$PATH:/usr/gnu/bin])
+
+AC_MSG_CHECKING([whether to build documentation])
+AC_ARG_ENABLE(docs, AC_HELP_STRING([--enable-docs],
+ [Enable building of documentation]),
+ [build_docs="${enableval}"], [build_docs="no"])
+AC_MSG_RESULT([${build_docs}])
+if test "x${build_docs}" = xyes && test "x${GROFF}" = xnone ; then
+ AC_MSG_ERROR([can't build documentation without groff])
+fi
+
+AM_CONDITIONAL(BUILD_DOCS, [test x$build_docs = xyes])
+AM_CONDITIONAL(HAVE_PS2PDF, [test x$PS2PDF != xnone])
+
AC_OUTPUT([Makefile
xtrans.pc])