summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-05-11 22:44:52 +0000
committerSøren Sandmann Pedersen <sandmann@daimi.au.dk>2005-05-11 22:44:52 +0000
commitd628bf24f2bf0d017394b6961784d7ac5b33f46b (patch)
tree47bde609b0b274f318c2adf21b98622c2551bfc2 /configure.ac
parentc814f30e9a5dc48a24c20517334cf5f9c37e066a (diff)
downloadxorg-lib-libxtrans-d628bf24f2bf0d017394b6961784d7ac5b33f46b.tar.gz
lib/Xau:
- Update AUTHORS, COPYING from Keith's tree - Don't use gcc specific "-include config.h" - Add autogen.sh lib/xtrans: - Add AUTHORS, COPYING, ChangeLog, Makefile.am, NEWS, README, autogen.sh, configure.ac, xtrans.pc.in xc/lib/Xau: - Add conditionalized #include <config.h> util/modular/symlink.sh - Add functions symlink_lib_xau() and symlink_lib_xtrans() util/modular/addconfig.h - New script that adds #include <config.h> to files
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac53
1 files changed, 53 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..0896e0e
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,53 @@
+dnl
+dnl $Id$
+dnl
+dnl Copyright © 2003 Keith Packard, Noah Levitt
+dnl
+dnl Permission to use, copy, modify, distribute, and sell this software and its
+dnl documentation for any purpose is hereby granted without fee, provided that
+dnl the above copyright notice appear in all copies and that both that
+dnl copyright notice and this permission notice appear in supporting
+dnl documentation, and that the name of Keith Packard not be used in
+dnl advertising or publicity pertaining to distribution of the software without
+dnl specific, written prior permission. Keith Packard makes no
+dnl representations about the suitability of this software for any purpose. It
+dnl is provided "as is" without express or implied warranty.
+dnl
+dnl KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+dnl INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+dnl EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+dnl CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+dnl DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+dnl TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+dnl PERFORMANCE OF THIS SOFTWARE.
+dnl
+dnl Process this file with autoconf to create configure.
+
+AC_PREREQ([2.57])
+AC_INIT(xtrans, 0.2, [keithp@keithp.com], xtrans)
+AM_INIT_AUTOMAKE([dist-bzip2])
+AM_MAINTAINER_MODE
+
+# Because xtrans is included into other modules rather than being linked
+# with, these defines have to be added to the cflags line
+
+# fchown()
+
+AC_CHECK_FUNC(fchown, [fchown_define="-DHAS_FCHOWN"], [fchown_define=""])
+
+AC_SUBST(fchown_define)
+
+# sticky bit
+#
+# if any system exists without sticky dir bits this
+# needs to be redone with a real autoconf test
+
+sticky_bit_define="-DHAS_STICKY_DIR_BIT"
+
+AC_SUBST(sticky_bit_define)
+
+
+
+AC_OUTPUT([Makefile
+ xtrans.pc])
+