summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 16:39:03 -0500
committerJames Cloos <cloos@jhcloos.com>2007-12-06 16:39:03 -0500
commit257f7118e71ef4aa59bec55cd43bf1bdd228d152 (patch)
treec2e2e19c31809a586b37f3b7513109d06d077b9a /Makefile.am
parent378417f12b1a8839c2943822545e8a9a74543d6d (diff)
downloadxorg-proto-printproto-257f7118e71ef4aa59bec55cd43bf1bdd228d152.tar.gz
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0ce1e0e..5492c79 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,3 +7,13 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = printproto.pc
EXTRA_DIST = autogen.sh printproto.pc.in
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog