summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 16:39:06 -0500
committerJames Cloos <cloos@jhcloos.com>2007-12-06 16:39:06 -0500
commit40fded7637faa3548052cbf419d48ea081b1b5cb (patch)
treeeae5c694c9ce04187fd4f1c71421e33826b7ebab /Makefile.am
parent2740cf052e07fef8808991863409829bab22f016 (diff)
downloadxorg-proto-resourceproto-40fded7637faa3548052cbf419d48ea081b1b5cb.tar.gz
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 65ebd56..e2df548 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,3 +6,13 @@ pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = resourceproto.pc
EXTRA_DIST = autogen.sh resourceproto.pc.in
+
+EXTRA_DIST += ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog