summaryrefslogtreecommitdiff
path: root/specs/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'specs/Makefile.am')
-rw-r--r--specs/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/specs/Makefile.am b/specs/Makefile.am
index 6fcafe7..a5d34fd 100644
--- a/specs/Makefile.am
+++ b/specs/Makefile.am
@@ -23,6 +23,7 @@
if ENABLE_SPECS
doc_sources = \
+ appgroup.xml \
dbe.xml \
dpms.xml \
evi.xml \
@@ -35,7 +36,7 @@ doc_sources = \
tog-cup.xml \
xtest.xml
-dist_doc_DATA = $(doc_sources)
+dist_doc_DATA = $(doc_sources) appendix.xml
if HAVE_XMLTO
doc_DATA = $(doc_sources:.xml=.html)
@@ -57,16 +58,16 @@ CLEANFILES = $(doc_DATA)
SUFFIXES = .xml .ps .pdf .txt .html
-.xml.txt:
+%.txt: %.xml $(dist_doc_DATA)
$(AM_V_GEN)$(XMLTO) $(XMLTO_FLAGS) txt $<
-.xml.html:
+%.html: %.xml $(dist_doc_DATA)
$(AM_V_GEN)$(XMLTO) $(XMLTO_FLAGS) xhtml-nochunks $<
-.xml.pdf:
+%.pdf: %.xml $(dist_doc_DATA)
$(AM_V_GEN)$(XMLTO) $(XMLTO_FLAGS) --with-fop pdf $<
-.xml.ps:
+%.ps: %.xml $(dist_doc_DATA)
$(AM_V_GEN)$(XMLTO) $(XMLTO_FLAGS) --with-fop ps $<
endif HAVE_XMLTO