summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2009-03-24 17:25:56 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2009-03-24 19:52:15 -0700
commite3bc51e4ea2dce1901c4f7ce43df2f456ececdcf (patch)
treea1d98585821e5fa3108a44cb594e4062e8ae054f /Makefile.am
parentcc3112b6d0434d8e7ecbe3832a5aa48cd0f5185d (diff)
downloadxorg-util-makedepend-e3bc51e4ea2dce1901c4f7ce43df2f456ececdcf.tar.gz
Use XORG_CHANGELOG, XORG_CWARNFLAGS, and XORG_WITH_LINT macros
Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d01b5ee..1282d15 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -15,6 +15,7 @@ makedepend_SOURCES = include.c \
imakemdep.h
AM_CPPFLAGS = -DOBJSUFFIX=\".${OBJEXT}\" -DINCLUDEDIR=\"/usr/include\"
+AM_CFLAGS = $(CWARNFLAGS)
EXTRA_DIST = autogen.sh makedepend.man
@@ -57,6 +58,14 @@ MAINTAINERCLEANFILES = ChangeLog
.PHONY: ChangeLog
ChangeLog:
- (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+ $(CHANGELOG_CMD)
dist-hook: ChangeLog
+
+if LINT
+ALL_LINT_FLAGS=$(LINT_FLAGS) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
+ $(AM_CPPFLAGS) $(CPPFLAGS)
+
+lint:
+ $(LINT) $(ALL_LINT_FLAGS) $(makedepend_SOURCES)
+endif LINT